Skip to main content
VulnerabilityPublished Updated

Duplicate Advisory: uutils coreutils has an Improper Input Validation issue

Affects coreutilsSource GCVE Database

0

CVSS 5.5 Medium : upgrade to 0.6.0 when convenient.

Data as of 7 Jul 2026, 12:28 UTC

CVSS 3.1 base score
5.5Medium
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 0.6.0
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H

What to do

Upgrade coreutils to 0.6.0.

Affected software

ProductAffectedFixed in
crates.iocoreutilsAffected
  • <0.6.0
Fixed in
  • 0.6.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

If you cannot patch yet, users should avoid using the 'kill -1' command with uutils coreutils versions prior to 0.6.0. Consider using GNU coreutils as an alternative where this issue does not exist.

Description

### Duplicate Advisory This advisory has been withdrawn because it is a duplicate of GHSA-p6rv-2qpm-fwvg. This link is maintained to preserve external references. ### Original Description An argument parsing error in the kill utility of uutils coreutils incorrectly interprets kill -1 as a request to send the default signal (SIGTERM) to PID -1. Sending a signal to PID -1 causes the kernel to terminate all processes visible to the caller, potentially leading to a system crash or massive process termination. This differs from GNU coreutils, which correctly recognizes -1 as a signal number in this context and would instead report a missing PID argument.

References

Community reviews

Loading reviews…