Skip to main content
VulnerabilityPublished Updated

Duplicate Advisory: uutils coreutils has an Incorrect Provision of Specified Functionality Issue in its cut Utility

Affects coreutilsSource GCVE Database

0

CVSS 3.3 Low : upgrade to 0.8.0 when convenient.

Data as of 7 Jul 2026, 12:28 UTC

CVSS 3.1 base score
3.3Low
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 0.8.0
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N

What to do

Upgrade coreutils to 0.8.0.

Affected software

ProductAffectedFixed in
crates.iocoreutilsAffected
  • <0.8.0
Fixed in
  • 0.8.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Users should upgrade to uutils coreutils version 0.8.0 or later where this issue is presumably resolved. Until then, avoid using the combination of -s, -z, and -d '' options together in the cut utility to prevent incorrect output.

Description

### Duplicate Advisory This advisory has been withdrawn because it is a duplicate of GHSA-pmfc-4wjj-gmhx. This link is maintained to preserve external references. ### Original Description A logic error in the cut utility of uutils coreutils causes the utility to ignore the -s (only-delimited) flag when using the -z (null-terminated) and -d '' (empty delimiter) options together. The implementation incorrectly routes this specific combination through a specialized newline-delimiter code path that fails to check the record suppression status. Consequently, uutils cut emits the entire record plus a NUL byte instead of suppressing it. This divergence from GNU coreutils behavior creates a data integrity risk for automated pipelines that rely on cut -s to filter out undelimited data.

References

Community reviews

Loading reviews…