Skip to main content
VulnerabilityPublished Updated

Duplicate Advisory: vLLM introduced enhanced protection for CVE-2025-62164

Affects vllmSource GCVE Database

0

Mentioned vulnerabilities

CVSS 8.8 High : upgrade to 0.13.0 soon.

Data as of 12 Sep 2026, 00:46 UTC

CVSS 3.1 base score
8.8High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 0.13.0
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

What to do

Upgrade vllm to 0.13.0.

Affected software

ProductAffectedFixed in
PyPIvllmAffected
  • >=0.10.2 <0.13.0
Fixed in
  • 0.13.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available for this vulnerability. Users should upgrade vLLM to a fixed version at or beyond 0.13.0 to address the root cause. Prior mitigations that only disabled the prompt-embeds feature by default are insufficient. No additional vendor advisory content contradicts this guidance.

Description

### Duplicate Advisory This advisory has been withdrawn because it is a duplicate of GHSA-mcmc-2m55-j8jj. This link is maintained to preserve external references. ### Original Description vLLM versions >= 0.10.2 and < 0.13.0 are missing sparse tensor validation in multimodal embeddings processing. Because PyTorch disables sparse tensor invariant checks by default, an attacker can submit crafted embedding requests with malformed (negative or out-of-bounds) tensor indices, when the prompt-embeds feature is enabled, to trigger crashes or resource exhaustion (denial of service), with potential for out-of-bounds/write-what-where memory corruption. This continues CVE-2025-62164, whose prior fix only disabled the feature by default rather than addressing the root cause.

References

Community reviews

Loading reviews…