CVE-2026-119196: Duplicity · pyasn1 has quadratic CPU consumption in constructed BIT STRING decoding
Affects duplicitySource GCVE Database
Not known to be exploited · CVSS 7.5 High : upgrade to 0.8.03 soon.
Data as of 31 Oct 2026, 17:08 UTC
Thin evidence
One scorer or none| CNA (GitHub_M) | CVSS 3.1 | 7.5 |
|---|
- Patch
- Available – fixed in 0.8.03
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:HExploitation evidence
Disclosed: evidence found.
CVE published 29 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade duplicity to 0.8.03.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Homebrewduplicitypkg:brew/duplicityOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A fix is available in pyasn1 version 0.8.03. Users of affected versions should upgrade to 0.8.03 or later to remediate this vulnerability. No other mitigations are specified or required if the patch is applied. Applications should ensure they do not process untrusted ASN.1 input with vulnerable pyasn1 versions without patching.
Description
CVE-2026-119196 is a high-severity vulnerability in pyasn1 through version 0.6.4 used by Duplicity, where decoding constructed BIT STRING values with many fragments causes quadratic CPU consumption. This can lead to CPU exhaustion and denial of service when processing attacker-controlled ASN.1 data. The issue affects BER and CER decoders and certain schema-driven DER decoding paths. The vulnerability is fixed in pyasn1 version 0.8.03.
References
- github.com/pyasn1/pyasn1/security/advisories/GHSA-2qm8-x737-gmw5 (opens in a new tab)
- nvd.nist.gov/vuln/detail/CVE-2026-119196 (opens in a new tab)
- github.com/pyasn1/pyasn1/pull/132 (opens in a new tab)
- github.com/pyasn1/pyasn1/commit/73ba7b043cc7e92cb37f16f2c955bff93b0e6f6c (opens in a new tab)
- github.com/pyasn1/pyasn1 (opens in a new tab)
- github.com/pyasn1/pyasn1/releases/tag/v0.6.5 (opens in a new tab)