Skip to main content
VulnerabilityPublished

@dynatrace-oss/dynatrace-mcp-server's create_dynatrace_notebook missing the human-approval gate

Affects @dynatrace-oss/dynatrace-mcp-serverSource GCVE Database

0

CVSS 3.7 Low : upgrade to 1.8.7 when convenient.

Data as of 30 Jul 2026, 07:24 UTC

CVSS 3.1 base score
3.7Low
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 1.8.7
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:L/A:N

What to do

Upgrade @dynatrace-oss/dynatrace-mcp-server to 1.8.7.

Affected software

ProductAffectedFixed in
npm@dynatrace-oss/dynatrace-mcp-serverAffected
  • <1.8.7
Fixed in
  • 1.8.7

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

If you cannot patch yet, restrict access to the MCP server to trusted users and ensure authentication is enforced to prevent unauthenticated calls. Monitor for unusual notebook creation activity. The vendor advisory or repository should be consulted for updates on official fixes or temporary mitigations.

Description

The @dynatrace-oss/dynatrace-mcp-server package contains a vulnerability in the create_dynatrace_notebook tool where a required human-approval gate is missing. This omission allows an unauthenticated caller to create persistent tenant-visible notebooks with arbitrary content, including embedded DQL queries that execute under the permissions of any tenant user who opens the notebook. Unlike other write tools in the package, create_dynatrace_notebook does not require operator consent before execution. This vulnerability affects versions prior to 1.8.7.

References

Community reviews

Loading reviews…