Skip to main content
VulnerabilityPublished Updated

CVE-2026-118264: Rejected WebSocket upgrades can bypass Echo route-level access controls

Affects github.com/labstack/echo/v4Source GCVE Database

0
Authoritative record:CVE-2026-118264· Critical 9.1

Not known to be exploited · CVSS 9.1 Critical : upgrade to 4.16.1 as a priority.

Data as of 28 Oct 2026, 20:14 UTC

CVSS 4.0 base score
9.1Critical
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 4.16.1, 5.4.1
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 28 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade github.com/labstack/echo/v4 to 4.16.1; github.com/labstack/echo/v5 to 5.4.1.

Affected software

ProductAffectedFixed in
Gogithub.com/labstack/echo/v4Affected
  • >=4.0.0 <4.16.1
Fixed in
  • 4.16.1
Gogithub.com/labstack/echo/v5Affected
  • >=5.0.0 <5.4.1
Fixed in
  • 5.4.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade Echo to version v4.16.1 or later, or v5.4.1 or later, where the vulnerability is fixed. The fix ensures that WebSocket upgrades are properly validated by the upstream before entering a tunnel. As a workaround, reject WebSocket upgrade requests before they reach affected Echo proxy routes or enforce authorization independently at every upstream resource. Note that simply returning a non-101 response from the upstream does not mitigate the vulnerability.

Description

Echo versions prior to v4.16.1 and v5.4.1 contain a vulnerability where rejected WebSocket upgrade requests can bypass route-level access controls. This occurs because Echo's proxy middleware forwards subsequent HTTP requests on a connection with a rejected upgrade directly to the upstream without passing through Echo's router or middleware, potentially bypassing authentication or authorization enforced at Echo routes. Exploitation requires an accessible proxy route, an upstream that rejects the upgrade without closing the connection, and a target resource on that upstream without its own authorization. Fixed in versions v4.16.1 and v5.4.1.

References

Community reviews

Loading reviews…