CVE-2026-70600: Electron · Cross-origin iframe can position native autofill popup
Affects electronSource GCVE Database
Not known to be exploited · CVSS 3.1 Low : upgrade to 39.8.8 when convenient.
Data as of 3 Nov 2026, 22:58 UTC
- EPSS
- 0.1% chance of exploitation in 30 days – higher than 7% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 39.8.8, 40.9.1, 41.2.1 +1
CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:N/I:L/A:NExploitation evidence
Disclosed: evidence found.
CVE published 5 Aug 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 3 Nov 2026.
What to do
Upgrade to a fixed release listed under Affected software.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| npmelectron | Affected
| Fixed in
|
| npmelectron | Affected
| Fixed in
|
| npmelectron | Affected
| Fixed in
|
| npmelectron | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A fix is available in Electron versions 39.8.8, 40.9.0, 41.2.1, and 42.0.0-beta.3. Users and developers should upgrade to one of these versions or later. As a workaround, avoid embedding untrusted content in iframes inside windows that also display trusted UI. No other mitigations are specified.
Description
A vulnerability in Electron allows a cross-origin iframe to position the native autofill popup outside its bounds, overlaying the embedding page's UI. This can enable clickjacking or spoofing of trusted UI elements. Only applications embedding untrusted content in iframes within windows that also display trusted UI are affected. Versions prior to 39.8.8 are vulnerable. Fixed versions include 39.8.8 and later. The vulnerability has a low CVSS score of 3.1.