CVE-2025-54949: ExecuTorch heap buffer overflow vulnerability
Affects executorchSource GCVE Database
Not known to be exploited · CVSS 9.8 Critical : upgrade to 0.7.0 as a priority.
Data as of 27 Oct 2026, 02:47 UTC
- Patch
- Available – fixed in 0.7.0
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 7 Aug 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade executorch and org.pytorch:executorch-android and github.com/pytorch/executorch to 0.7.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| PyPIexecutorch | Affected
| Fixed in
|
| Mavenorg.pytorch:executorch-android | Affected
| Fixed in
|
| SwiftURLgithub.com/pytorch/executorch | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Users should upgrade ExecuTorch to version 0.7.0 or later, where this heap buffer overflow vulnerability has been fixed. Applying this official fix fully mitigates the issue.
Description
ExecuTorch versions prior to 0.7.0 contain a heap buffer overflow vulnerability in the model loading component. This flaw can lead to remote code execution or other severe impacts. The vulnerability is tracked as CVE-2025-54949 and has a critical CVSS score of 9.8. A fix is available in version 0.7.0.