Skip to main content
VulnerabilityPublished Updated

CVE-2025-30402: ExecuTorch vulnerable to Heap-based Buffer Overflow attack

Affects executorchSource GCVE Database

0
Authoritative record:CVE-2025-30402· High 8.1

Not known to be exploited · CVSS 8.1 High : upgrade to 0.7.0 soon.

Data as of 27 Oct 2026, 02:47 UTC

CVSS 3.1 base score
8.1High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 0.7.0, 0.7.0-rc1
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 11 Jul 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade executorch to 0.7.0; org.pytorch:executorch-android and github.com/pytorch/executorch to 0.7.0-rc1.

Affected software

ProductAffectedFixed in
PyPIexecutorchAffected
  • <0.7.0
Fixed in
  • 0.7.0
Mavenorg.pytorch:executorch-androidAffected
  • <0.7.0-rc1
Fixed in
  • 0.7.0-rc1
SwiftURLgithub.com/pytorch/executorchAffected
  • <0.7.0-rc1
Fixed in
  • 0.7.0-rc1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Users should upgrade ExecuTorch to version 0.7.0 or 0.7.0-rc1 or later, where this vulnerability has been fixed. Since a patch is available, applying the official update is the recommended mitigation.

Description

ExecuTorch versions prior to 0.7.0 and 0.7.0-rc1 contain a heap-based buffer overflow vulnerability in the method loading process. This flaw can cause the runtime to crash and may allow an attacker to execute arbitrary code or cause other harmful effects. The vulnerability is tracked as CVE-2025-30402 and has a high severity rating with a CVSS score of 8.1. A fix is available in versions 0.7.0 and 0.7.0-rc1.

References

Community reviews

Loading reviews…