Exim4: Exim before 4.99.5 allows directory traversal to access files outside of the spool area, and consequently gain
Affects exim4Source GCVE Database
Not known to be exploited · CVSS 8.4 High · fixed in 4.95-4ubuntu2.11 : patch exim4 soon.
Data as of 30 Oct 2026, 06:59 UTC
- EPSS
- 0.3% chance of exploitation in 30 days – higher than 32% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 4.95-4ubuntu2.11, 4.97-4ubuntu4.7, 4.99.1-1ubuntu1.4
CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 24 Jul 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade the Ubuntu exim4 to 4.95-4ubuntu2.11 (package) or 4.97-4ubuntu4.7 (package) or 4.99.1-1ubuntu1.4 (package).
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Ubuntu 26.04 LTSexim4pkg:deb/ubuntu/exim4?arch=source&distro=resoluteOther threats | Affected
| Fixed in
|
Ubuntu 24.04 LTSexim4pkg:deb/ubuntu/exim4?arch=source&distro=nobleOther threats | Affected
| Fixed in
|
Ubuntu 22.04 LTSexim4pkg:deb/ubuntu/exim4?arch=source&distro=jammyOther threats | Affected
| Fixed in
|
Ubuntu Pro 20.04 LTSexim4pkg:deb/ubuntu/exim4?arch=source&distro=esm-infra/focalOther threats | Affected
| Fixed in– |
Ubuntu Pro 18.04 LTSexim4pkg:deb/ubuntu/exim4?arch=source&distro=esm-infra/bionicOther threats | Affected
| Fixed in– |
Ubuntu Pro 16.04 LTSexim4pkg:deb/ubuntu/exim4?arch=source&distro=esm-infra-legacy/xenialOther threats | Affected
| Fixed in– |
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A fix is available in Exim version 4.99.5 and later. Users should upgrade to version 4.99.5 or newer to remediate this vulnerability. Patch status is confirmed by the version cutoff. No vendor advisory content was provided to indicate alternative mitigations or no-action status.
Description
Exim versions before 4.99.5 contain a directory traversal vulnerability that allows attackers to access files outside the intended spool area by mishandling queue-name related arguments. This flaw can lead to privilege escalation. The vulnerability affects multiple Ubuntu LTS versions with Exim packages prior to specific patched versions.
References
- ubuntu.com/security/CVE-2026-66140 (opens in a new tab)
- cve.org/CVERecord?id=CVE-2026-66140 (opens in a new tab)
- openwall.com/lists/oss-security/2026/07/22/9 (opens in a new tab)
- exim.org/static/doc/security/EXIM-Security-2026-06-22.1/EXIM-Security-2026-06-22.1.txt (opens in a new tab)
- openwall.com/lists/oss-security/2026/07/22/9 (opens in a new tab)
- ubuntu.com/security/notices/USN-8590-1 (opens in a new tab)