Skip to main content
VulnerabilityPublished Updated

CVE-2026-66141: Exim4 · Exim before 4.99.5 allows .forward privilege escalation because force_command for a pipe

Affects exim4Source GCVE Database

0
Compare

Not known to be exploited · CVSS 7.8 High · fixed in 4.95-4ubuntu2.11 : patch exim4 soon.

Data as of 30 Oct 2026, 06:59 UTC

CVSS 3.1 base score
7.8High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.1% chance of exploitation in 30 days – higher than 3% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 4.95-4ubuntu2.11, 4.97-4ubuntu4.7, 4.99.1-1ubuntu1.4
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 24 Jul 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade the Ubuntu exim4 to 4.95-4ubuntu2.11 (package) or 4.97-4ubuntu4.7 (package) or 4.99.1-1ubuntu1.4 (package).

Affected software

ProductAffectedFixed in
Ubuntu 26.04 LTSexim4pkg:deb/ubuntu/exim4?arch=source&distro=resoluteOther threatsAffected
  • <4.99.1-1ubuntu1.4
Fixed in
  • 4.99.1-1ubuntu1.4
Ubuntu 24.04 LTSexim4pkg:deb/ubuntu/exim4?arch=source&distro=nobleOther threatsAffected
  • <4.97-4ubuntu4.7
Fixed in
  • 4.97-4ubuntu4.7
Ubuntu 22.04 LTSexim4pkg:deb/ubuntu/exim4?arch=source&distro=jammyOther threatsAffected
  • <4.95-4ubuntu2.11
Fixed in
  • 4.95-4ubuntu2.11
Ubuntu Pro 20.04 LTSexim4pkg:deb/ubuntu/exim4?arch=source&distro=esm-infra/focalOther threatsAffected
  • 4.92.1-1ubuntu3 – 4.93~RC2-1ubuntu1
17 affected builds
Fixed in–
Ubuntu Pro 18.04 LTSexim4pkg:deb/ubuntu/exim4?arch=source&distro=esm-infra/bionicOther threatsAffected
  • 4.89-5ubuntu1 – 4.90.1-1ubuntu1.10+esm6
20 affected builds
Fixed in–
Ubuntu Pro 16.04 LTSexim4pkg:deb/ubuntu/exim4?arch=source&distro=esm-infra-legacy/xenialOther threatsAffected
  • 4.86-3ubuntu1 – 4.86.2-2ubuntu2.6+esm9
20 affected builds
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available in Exim version 4.99.5 and later. Users should upgrade to version 4.99.5 or newer to remediate this vulnerability. Since this is not a cloud service, remediation depends on applying the official patch or upgrading the affected Exim4 packages.

Description

Exim versions before 4.99.5 contain a vulnerability that allows privilege escalation via mishandling of force_command in a pipe transport for .forward files. This flaw can be exploited locally to gain elevated privileges. The issue affects multiple Ubuntu LTS versions with Exim packages prior to specific patched versions.

References

Community reviews

Loading reviews…