CVE-2025-8869: pip · Fallback Tar Extraction
Affects pipSource GCVE Database
Not known to be exploited · CVSS 5.9 Medium : upgrade to 25.3.0 when convenient.
Data as of 4 Nov 2026, 17:16 UTC
Thin evidence
One scorer or none| CNA (PSF) | CVSS 4.0 | 5.9 |
|---|
- Patch
- Available – fixed in 25.3.0
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:A/VC:N/VI:H/VA:N/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 25 Sep 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 4 Nov 2026.
What to do
Upgrade pip to 25.3.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Bitnamipippkg:bitnami/pipOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
Description
When extracting a tar archive pip may not check symbolic links point into the extraction directory if the tarfile module doesn't implement PEP 706. Note that upgrading pip to a "fixed" version for this vulnerability doesn't fix all known vulnerabilities that are remediated by using a Python version that implements PEP 706. Note that this is a vulnerability in pip's fallback implementation of tar extraction for Python versions that don't implement PEP 706 and therefore are not secure to all vulnerabilities in the Python 'tarfile' module. If you're using a Python version that implements PEP 706 then pip doesn't use the "vulnerable" fallback code. Mitigations include upgrading to a version of pip that includes the fix, upgrading to a Python version that implements PEP 706 (Python >=3.9.17, >=3.10.12, >=3.11.4, or >=3.12), applying the linked patch, or inspecting source distributions (sdists) before installation as is already a best-practice.
References
- github.com/pypa/pip/pull/13550 (opens in a new tab)
- mail.python.org/archives/list/security-announce@python.org/thread/IF5A3GCJY3VH7BVHJKOWOJFKTW7VFQEN/ (opens in a new tab)
- nvd.nist.gov/vuln/detail/CVE-2025-8869 (opens in a new tab)
- lists.debian.org/debian-lts-announce/2025/10/msg00028.html (opens in a new tab)