Skip to main content
VulnerabilityPublished Updated

CVE-2026-6357: pip Vulnerable to Inclusion of Functionality from Untrusted Control Sphere

Affects pipSource GCVE Database

0
Authoritative record:CVE-2026-6357· Medium 5.3

Not known to be exploited · CVSS 5.3 Medium : upgrade to 26.1 when convenient.

Data as of 27 Oct 2026, 00:07 UTC

CVSS 4.0 base score
5.3Medium
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 26.1
CVSS:4.0/AV:L/AC:L/AT:P/PR:H/UI:A/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 27 Apr 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade pip to 26.1.

Affected software

ProductAffectedFixed in
PyPIpipAffected
  • <26.1
Fixed in
  • 26.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

Description

pip prior to version 26.1 would run self-update check functionality after installing wheel files which required importing well-known Python modules names. These module imports were intentionally deferred to increase startup time of the pip CLI. The patch changes self-update functionality to run before wheels are installed to prevent newly-installed modules from being imported shortly after the installation of a wheel package. Users should still review package contents prior to installation.

References

Community reviews

Loading reviews…