CVE-2026-7768: @fastify/accepts-serializer Vulnerable to Denial of Service via Unbounded Accept Header Cache Growth
Affects @fastify/accepts-serializerSource GCVE Database
Not known to be exploited · CVSS 7.5 High : upgrade to 6.0.4 soon.
Data as of 27 Oct 2026, 00:07 UTC
- Patch
- Available – fixed in 6.0.4
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:HExploitation evidence
Disclosed: evidence found.
CVE published 4 May 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade @fastify/accepts-serializer to 6.0.4.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| npm@fastify/accepts-serializer | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
Description
### Impact `@fastify/accepts-serializer` cached serializer-selection results keyed by the request `Accept` header without a size limit or eviction policy. A remote unauthenticated client could send many distinct but matching `Accept` header variants to make the cache grow unbounded. Under sustained load, this can exhaust the Node.js heap and crash the process. ### Patches Update to `@fastify/accepts-serializer >= 6.0.4`. The cache is now bounded by an LRU with a default size of 100 entries, configurable via the new `cacheSize` plugin option. ### Workarounds None. Upgrade is required.