CVE-2026-63349: Fastmcp · AnyIO run_process/open_process ignores extra_groups and can retain parent supplementary groups
Affects fastmcpSource GCVE Database
Not known to be exploited · CVSS 7.0 High : upgrade to 3.4.5 soon.
Data as of 3 Nov 2026, 22:58 UTC
- EPSS
- 0.1% chance of exploitation in 30 days – higher than 1% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 3.4.5
CVSS:4.0/AV:L/AC:H/AT:P/PR:H/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 18 Sep 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 3 Nov 2026.
What to do
Upgrade fastmcp to 3.4.5.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Homebrewfastmcppkg:brew/fastmcpOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch is available in AnyIO version 3.4.5 that corrects the handling of the extra_groups argument in run_process() and open_process(). Users should upgrade to version 3.4.5 or later to resolve this issue. No other mitigation is indicated by the vendor advisory.
Description
AnyIO versions from 3.4.2_2 up to but not including 3.4.5 contain a vulnerability where the extra_groups argument in run_process() and open_process() is mishandled. This causes child processes to retain parent supplementary groups instead of properly clearing or setting them, leading to a POSIX privilege-dropping correctness issue. The flaw can cause TypeError if both group and extra_groups are supplied. A fix is available in version 3.4.5.
References
- github.com/agronholm/anyio/security/advisories/GHSA-3w57-8xmc-8v26 (opens in a new tab)
- github.com/agronholm/anyio/pull/1209 (opens in a new tab)
- github.com/agronholm/anyio/commit/eb562e6462ee46b1904e50b02ce00a858cdeb200 (opens in a new tab)
- github.com/agronholm/anyio (opens in a new tab)
- github.com/agronholm/anyio/releases/tag/4.14.2 (opens in a new tab)