CVE-2025-68158: Fastmcp · Authlib has 1-click Account Takeover vulnerability
Affects fastmcpSource GCVE Database
Not known to be exploited · CVSS 5.7 Medium : upgrade to 2.14.1 when convenient.
Data as of 3 Nov 2026, 22:58 UTC
- EPSS
- 0.2% chance of exploitation in 30 days – higher than 19% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 2.14.1
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:N/A:NExploitation evidence
Disclosed: evidence found.
CVE published 13 Aug 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 3 Nov 2026.
What to do
Upgrade fastmcp to 2.14.1.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Homebrewfastmcppkg:brew/fastmcpOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch is available in Authlib version 2.14.1 that fixes this vulnerability. Users should upgrade to version 2.14.1 or later. The fix involves binding the OAuth state parameter to the user's session to prevent CSRF attacks. Until upgrading, applications should avoid using cache-backed state storage or implement additional session binding to the state parameter as a temporary mitigation.
Description
Authlib versions from 2.12.3 up to but not including 2.14.1 have a vulnerability in cache-backed state storage used during OAuth flows. The state parameter used for CSRF protection is not tied to the initiating user session, allowing an attacker to perform a login CSRF attack. This can lead to account takeover if the application links accounts upon login callbacks. The vulnerability is fixed in version 2.14.1.
References
- github.com/authlib/authlib/security/advisories/GHSA-fg6f-75jq-6523 (opens in a new tab)
- nvd.nist.gov/vuln/detail/CVE-2025-68158 (opens in a new tab)
- github.com/authlib/authlib/commit/2808378611dd6fb2532b189a9087877d8f0c0489 (opens in a new tab)
- github.com/authlib/authlib/commit/7974f45e4d7492ab5f527577677f2770ce423228 (opens in a new tab)
- github.com/authlib/authlib (opens in a new tab)