CVE-2026-32871: FastMCP OpenAPI Provider has an SSRF & Path Traversal Vulnerability
Affects fastmcpSource GCVE Database
Not known to be exploited · CVSS 10.0 Critical : upgrade to 3.2.0 as a priority.
Data as of 27 Oct 2026, 17:29 UTC
- Patch
- Available – fixed in 3.2.0
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:HExploitation evidence
Disclosed: evidence found.
CVE published 2 Apr 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade fastmcp to 3.2.0.
Patches and advisories
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| PyPIfastmcp | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A fix is available in FastMCP version 3.2.0 that addresses this vulnerability by URL-encoding all path parameter values before substitution, preventing path traversal sequences from being interpreted. Users should upgrade to version 3.2.0 or later to remediate this issue. No additional mitigation steps are required if the fix is applied.
Description
FastMCP's OpenAPIProvider contains a critical vulnerability (CVE-2026-32871) in its URL construction logic where path parameters are substituted without URL encoding. This allows an authenticated attacker to perform Server-Side Request Forgery (SSRF) combined with path traversal by injecting traversal sequences into path parameters. As a result, attackers can access internal backend endpoints outside the intended API scope, inheriting the MCP provider's authorization context. This vulnerability enables unauthorized access to sensitive internal APIs, privilege escalation, and potential data exfiltration or service disruption.
References
- github.com/PrefectHQ/fastmcp/security/advisories/GHSA-vv7q-7jx5-f767 (opens in a new tab)
- nvd.nist.gov/vuln/detail/CVE-2026-32871 (opens in a new tab)
- github.com/PrefectHQ/fastmcp/pull/3507 (opens in a new tab)
- github.com/PrefectHQ/fastmcp/commit/40bdfb6b1de0ce30609ee9ba5bb95ecd04a9fb71 (opens in a new tab)
- access.redhat.com/errata/RHSA-2026:36350 (opens in a new tab)
- access.redhat.com/security/cve/CVE-2026-32871 (opens in a new tab)
- bugzilla.redhat.com/show_bug.cgi?id=2454434 (opens in a new tab)
- github.com/PrefectHQ/fastmcp (opens in a new tab)
- github.com/PrefectHQ/fastmcp/releases/tag/v3.2.0 (opens in a new tab)
- github.com/pypa/advisory-database/tree/main/vulns/fastmcp/PYSEC-2026-338.yaml (opens in a new tab)
- pypi.org/project/fastmcp (opens in a new tab)
- security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-32871.json (opens in a new tab)