CVE-2025-69196: jlowin fastmcp · Incorrect Authorization
Affects jlowin fastmcpSource CVE Database V5
Not known to be exploited · CVSS 7.4 High : upgrade to 2.14.2 soon.
Data as of 30 Oct 2026, 11:52 UTC
- EPSS
- 0.3% chance of exploitation in 30 days – higher than 31% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 2.14.2
CVSS:4.0/AV:N/AC:H/AT:N/PR:N/UI:A/VC:H/VI:H/VA:N/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 16 Mar 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade fastmcp and jlowin/fastmcp to 2.14.2.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| jlowinfastmcp | Affected
| Fixed in
|
GitHubjlowin/fastmcppkg:github/jlowin/fastmcpOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade fastmcp to version 2.14.2 or later, where this authorization issue has been fixed. No other mitigation is indicated by the vendor advisory. Patch status is confirmed by Red Hat advisory.
Description
FastMCP is the standard framework for building MCP applications. Prior to version 2.14.2, the server does not properly respect the resource parameter submitted by the client in the authorization and token request. Instead of issuing the token explicitly for the MCP server, the token is issued for the base_url passed to the OAuthProxy during initialization. This issue has been patched 2.14.2.
References
- github.com/PrefectHQ/fastmcp/security/advisories/GHSA-5h2m-4q8j-pqpj (opens in a new tab)
- access.redhat.com/security/cve/CVE-2025-69196 (opens in a new tab)
- bugzilla.redhat.com/show_bug.cgi?id=2448179 (opens in a new tab)
- security.access.redhat.com/data/csaf/v2/vex/2025/cve-2025-69196.json (opens in a new tab)
- access.redhat.com/errata/RHSA-2026:36350 (opens in a new tab)