Skip to main content
VulnerabilityPublished

CVE-2026-96807: flatpak security update

Affects flatpakSource GCVE Database

0
Compare

Not known to be exploited · CVSS 4.0 Medium : upgrade to 1.10.2-16.oe2403sp1 when convenient.

Data as of 29 Oct 2026, 11:04 UTC

CVSS 3.1 base score
4.0Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.1% chance of exploitation in 30 days – higher than 1% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.10.2-16.oe2403sp1
CVSS:3.1/AV:L/AC:H/PR:N/UI:N/S:U/C:N/I:L/A:L

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 29 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade flatpak to 1.10.2-16.oe2403sp1.

Affected software

ProductAffectedFixed in
openEuler 24.03-LTS-SP1flatpakpkg:rpm/openEuler/flatpak&distro=openEuler-24.03-LTS-SP1Other threatsAffected
  • <1.10.2-16.oe2403sp1
Fixed in
  • 1.10.2-16.oe2403sp1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade Flatpak to version 1.10.2-16.oe2403sp1 or later to apply the official fix for this vulnerability.

Description

Flatpak before version 1.10.2-16.oe2403sp1 contains a vulnerability where a malicious sandboxed application can replace the file ~/.var/app/$appid/.ld.so with a symbolic link. This causes the regenerate_ld_cache process to write files to arbitrary locations. However, the filenames and content written are not attacker-controlled, limiting exploitability. This issue is fixed in version 1.10.2-16.oe2403sp1.

References

Community reviews

Loading reviews…