CVE-2025-71324: Flowise versions before 3.0.6 have an arbitrary file read vulnerability in the chatId parameter of
Affects FlowiseSource GCVE Database
Not known to be exploited · public detection template (Nuclei) · CVSS 7.5 High : upgrade to 3.0.6 soon.
Data as of 30 Oct 2026, 11:52 UTC
- EPSS
- 1.5% chance of exploitation in 30 days – higher than 75% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 3.0.6
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:NExploitation evidence
Disclosed: evidence found.
CVE published 26 Jun 2026
Detectable: evidence found.
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade flowiseai/Flowise to 3.0.6.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
GitHubflowiseai/Flowisepkg:github/flowiseai/FlowiseOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Since the vulnerability affects versions before 3.0.6, upgrading to version 3.0.6 or later is implied as a remediation step. Until an official fix is confirmed, restrict access to the affected endpoints and monitor for suspicious activity.
Description
Flowise versions before 3.0.6 have an arbitrary file read vulnerability in the chatId parameter of two API endpoints. The chatId parameter is not properly validated, allowing path traversal beyond the intended storage directory. This enables unauthenticated attackers to read sensitive files such as the default database file, exposing all database content.