CVE-2025-71334: Flowise versions 2.2.8 and earlier contain an arbitrary file access vulnerability due to missing
Affects FlowiseSource GCVE Database
Not known to be exploited · public detection template (Nuclei) · CVSS 9.3 Critical · fixed in 3.0.6 : patch Flowise as a priority.
Data as of 30 Oct 2026, 11:52 UTC
Thin evidence
One scorer or none| CNA (VulnCheck) | CVSS 4.0 | 9.3 |
|---|---|---|
| CNA (VulnCheck) | CVSS 3.1 | 9.8 |
- EPSS
- 4.3% chance of exploitation in 30 days – higher than 91% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 3.0.6
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:NExploitation evidence
t = 0 is the CVE’s publication on cve.org
Disclosed: evidence found.
CVE published 25 Jun 2026
Detectable: evidence found.
Weaponized: evidence found.
CISA SSVC: proof of concept public
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
Timeline
CVE ID reserved
by VulnCheck
, 5 days before disclosure
CVE published
on cve.org
, t = 0
CISA SSVC assessment
proof of concept public
, 13 hours after disclosure
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), CISA SSVC, the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Affected software
| Product | Affected | Fixed in |
|---|---|---|
GitHubflowiseai/Flowisepkg:github/flowiseai/FlowiseOther threats | Affected
| Fixed in– |
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A fix is available in Flowise version 3.0.6 and later. Users should upgrade to version 3.0.6 or newer to remediate this vulnerability. Until patched, restrict access to the affected API endpoints and monitor for suspicious activity related to file operations. Patch status is not explicitly confirmed in the provided data, but the version 3.0.6 is indicated as the fixed version, so upgrading is the recommended remediation.
Description
Flowise versions 2.2.8 and earlier contain an arbitrary file access vulnerability due to missing validation of chatflowId and chatId parameters. An unauthenticated attacker can exploit this by supplying path-traversal values to write and read arbitrary files via specific API endpoints. This arbitrary file write capability may lead to remote code execution.
References
- github.com/FlowiseAI/Flowise/security/advisories/GHSA-q67q-549q-p849 (opens in a new tab)
- nvd.nist.gov/vuln/detail/CVE-2025-71334 (opens in a new tab)
- github.com/FlowiseAI/Flowise/commit/8bd3de41533de78e4ef6c980e5704a1f9cb7ae6f (opens in a new tab)
- github.com/FlowiseAI/Flowise/commit/c2b830f279e454e8b758da441016b2234f220ac7 (opens in a new tab)
- vulncheck.com/advisories/flowise-arbitrary-file-access-via-missing-chat-flow-id-validation (opens in a new tab)