CVE-2026-44163: fluent-plugin-opentelemetry Has Denial of Service (DoS) via Large Payloads and Decompression Bombs in `in_opentelemetry`
Affects fluent-plugin-opentelemetrySource GCVE Database
Not known to be exploited · CVSS 5.3 Medium : upgrade to 0.5.3 when convenient.
Data as of 30 Oct 2026, 06:59 UTC
- EPSS
- 0.4% chance of exploitation in 30 days – higher than 36% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 0.5.3
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:LExploitation evidence
Disclosed: evidence found.
CVE published 15 Sep 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade fluent-plugin-opentelemetry to 0.5.3.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| RubyGemsfluent-plugin-opentelemetry | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade fluent-plugin-opentelemetry to version 0.5.3 or later, where this issue is fixed by enforcing maximum size thresholds on incoming request bodies and decompressed payloads. No other mitigation is required.
Description
A denial of service vulnerability exists in fluent-plugin-opentelemetry versions prior to 0.5.3. The in_opentelemetry HTTP input reads and decompresses incoming request bodies without size limits, allowing attackers to exhaust memory with large or highly compressed payloads. This can cause the Fluentd process to be terminated by the operating system, disrupting log collection and forwarding. The issue is fixed in version 0.5.3.
References
- github.com/fluent-plugins-nursery/fluent-plugin-opentelemetry/security/advisories/GHSA-2jc5-xhx8-qj6h (opens in a new tab)
- github.com/fluent-plugins-nursery/fluent-plugin-opentelemetry/commit/ce6c1f2a7741592c8a79afbe75fded9e8ebfa92d (opens in a new tab)
- github.com/fluent-plugins-nursery/fluent-plugin-opentelemetry (opens in a new tab)