SUSE fluidsynth · fluidsynth-2.5.6-1.1 on GA media
Affects SUSE fluidsynthSource GCVE Database
Not known to be exploited · fixed in Ubuntu package updates : update SUSE fluidsynth when convenient.
Data as of 31 Oct 2026, 20:20 UTC
Rated by Threat Radar · No CVSS score from NVD or the CNA
- EPSS
- 0.5% chance of exploitation in 30 days – higher than 48% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 2.5.6
Exploitation evidence
Disclosed: evidence found.
CVE published 8 Jul 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 31 Oct 2026.
What to do
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Ubuntu 26.04 LTSfluidsynthpkg:deb/ubuntu/fluidsynth?arch=source&distro=resoluteOther threats | Affected
| Fixed in– |
Ubuntu 24.04 LTSfluidsynthpkg:deb/ubuntu/fluidsynth?arch=source&distro=nobleOther threats | Affected
| Fixed in– |
Ubuntu 22.04 LTSfluidsynthpkg:deb/ubuntu/fluidsynth?arch=source&distro=jammyOther threats | Affected
| Fixed in– |
Ubuntu 20.04 LTSfluidsynthpkg:deb/ubuntu/fluidsynth?arch=source&distro=focalOther threats | Affected
| Fixed in– |
Ubuntu 18.04 LTSfluidsynthpkg:deb/ubuntu/fluidsynth?arch=source&distro=bionicOther threats | Affected
| Fixed in– |
Ubuntu 16.04 LTSfluidsynthpkg:deb/ubuntu/fluidsynth?arch=source&distro=xenialOther threats | Affected
| Fixed in– |
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A fix for this vulnerability is available in FluidSynth version 2.5.6. Users and administrators should upgrade to version 2.5.6 or later to remediate this issue. If upgrading is not immediately possible, disabling the TCP server feature can reduce remote attack risk. No other vendor advisories indicate additional mitigation steps.
Description
FluidSynth versions from 1.1.2 up to but not including 2.5.6 contain a vulnerability in the command handler where the pitch_bend_range command's channel argument is not properly bounds checked. This flaw can lead to an out-of-bounds heap write, potentially causing denial of service or code execution. The vulnerability can be exploited remotely if the TCP server is enabled or locally via the FluidSynth shell. The issue is fixed in version 2.5.6.
References
- suse.com/support/security/rating/ (opens in a new tab)
- ftp.suse.com/pub/projects/security/csaf/opensuse-su-2026_11211-1.json (opens in a new tab)
- suse.com/security/cve/CVE-2026-58264/ (opens in a new tab)
- ubuntu.com/security/CVE-2026-58264 (opens in a new tab)
- cve.org/CVERecord?id=CVE-2026-58264 (opens in a new tab)
- github.com/FluidSynth/fluidsynth/security/advisories/GHSA-mqmq-w63q-cj94 (opens in a new tab)
- github.com/FluidSynth/fluidsynth/pull/1796 (opens in a new tab)