Skip to main content
CVE-2025-6176VulnerabilityPublished Updated

Fonttools: Scrapy is vulnerable to a denial of service (DoS) attack due to flaws in brotli decompression

Affects fonttoolsSource GCVE Database

0
Authoritative record:CVE-2025-6176· High 7.5

Not known to be exploited · CVSS 7.5 High : upgrade to 4.60.1_2 or 4.45.0 soon.

Data as of 26 Oct 2026, 17:57 UTC

CVSS 3.0 base score
7.5High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.5% chance of exploitation in 30 days – higher than 45% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 4.60.1_2, 4.45.0
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 31 Oct 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade fonttools to 4.60.1_2 or 4.45.0.

Affected software

ProductAffectedFixed in
Homebrewfonttoolspkg:brew/fonttoolsOther threatsAffected
  • >=4.34.4_1 <4.45.0
  • >=4.49.0 <4.60.1_2
Fixed in
  • 4.45.0
  • 4.60.1_2

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Apply the official patches by upgrading fonttools to version 4.45.0 or later (including 4.60.1_2). These versions include the necessary security enhancements from brotli v1.2.0 to mitigate the decompression bomb attack vector. No additional mitigation is required if patched.

Description

Scrapy versions up to 2.13.3 contain a denial of service (DoS) vulnerability due to improper handling of brotli decompression. The existing protection against decompression bombs does not cover the brotli compression variant, allowing crafted data to cause excessive memory consumption and crash clients with less than 80GB of memory. This flaw is mitigated by security enhancements introduced in brotli version 1.2.0 and fixed in fonttools versions 4.45.0 and 4.60.1_2.

References

Community reviews

Loading reviews…