Skip to main content
VulnerabilityPublished Updated

CVE-2026-120065: For an updatable cursor over a table without OIDs that has an auto-increment int4 column, psqlODBC

Affects psqlodbcSource GCVE Database

0
Compare
Authoritative record:CVE-2026-120065· High 7.1

Not known to be exploited · CVSS 7.1 High.

Data as of 5 Nov 2026, 12:47 UTC

CVSS 3.1 base score
7.1High
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (PostgreSQL)CVSS 3.17.1
CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 2 Nov 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.

What to do

Affected software

ProductAffectedFixed in
Ubuntu 26.10psqlodbcpkg:deb/ubuntu/psqlodbc?arch=source&distro=stonkingOther threatsAffected
  • =1:17.00.0007-1
  • =1:18.00.0001-1
  • =1:18.00.0002-1
Fixed in–
Ubuntu 26.04 LTSpsqlodbcpkg:deb/ubuntu/psqlodbc?arch=source&distro=resoluteOther threatsAffected
  • =1:17.00.0006-2
  • =1:17.00.0007-1
Fixed in–
Ubuntu 24.04 LTSpsqlodbcpkg:deb/ubuntu/psqlodbc?arch=source&distro=nobleOther threatsAffected
  • =1:15.00.0000-1
  • =1:16.00.0000-1
Fixed in–
Ubuntu 22.04 LTSpsqlodbcpkg:deb/ubuntu/psqlodbc?arch=source&distro=jammyOther threatsAffected
  • =1:13.00.0000-1
  • =1:13.02.0000-1
  • =1:13.02.0000-2
Fixed in–
Ubuntu 20.04 LTSpsqlodbcpkg:deb/ubuntu/psqlodbc?arch=source&distro=focalOther threatsAffected
  • =1:11.00.0000-1
  • =1:12.00.0000-1
  • =1:12.01.0000-1
Fixed in–
Ubuntu 18.04 LTSpsqlodbcpkg:deb/ubuntu/psqlodbc?arch=source&distro=bionicOther threatsAffected
  • =1:09.06.0410-1
  • =1:10.00.0000-1
  • =1:10.01.0000-1
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade psqlODBC to version 18.00.0006 or later where this vulnerability is fixed. No other mitigation or workaround is indicated. Users should ensure that only trusted servers and users can create tables accessed by applications using updatable cursors until the update is applied.

Description

psqlODBC versions before 18.00.0006 have a vulnerability in handling updatable cursors over tables without OIDs that contain an auto-increment int4 column. The driver uses the column name in SQL statements without properly escaping double quotes, allowing a specially crafted column name containing double quotes to alter the executed SQL. This can lead to unauthorized modification of rows when the application uses positioned UPDATE or DELETE statements.

References

Community reviews

Loading reviews…