Skip to main content
CVE-2025-59933VulnerabilityPublished Updated

vips · For versions 8.17.1 and below, when libvips is compiled with support for PDF input via poppler, the pdfload operation

Affects vipsSource GCVE Database

0
Compare

Not known to be exploited · CVSS 7.8 High · fixed in 8.17.2 : patch vips soon.

Data as of 3 Nov 2026, 23:14 UTC

CVSS 3.1 base score
7.8High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 8.17.2
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 29 Sep 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 3 Nov 2026.

What to do

Affected software

ProductAffectedFixed in
Ubuntu 25.10vipspkg:deb/ubuntu/vips?arch=source&distro=questingOther threatsAffected
  • =8.16.0-2build1
  • =8.16.1-1
Fixed in–
Ubuntu Pro 24.04 LTSvipspkg:deb/ubuntu/vips?arch=source&distro=esm-apps/nobleOther threatsAffected
  • 8.14.3-1 – 8.15.1-1build1
10 affected builds
Fixed in–
Ubuntu Pro 22.04 LTSvipspkg:deb/ubuntu/vips?arch=source&distro=esm-apps/jammyOther threatsAffected
  • 8.10.5-2ubuntu1 – 8.12.1-1ubuntu0.1~esm3
7 affected builds
Fixed in–
Ubuntu Pro 20.04 LTSvipspkg:deb/ubuntu/vips?arch=source&distro=esm-apps/focalOther threatsAffected
  • 8.7.4-1build1 – 8.9.1-2ubuntu0.1~esm2
9 affected builds
Fixed in–
Ubuntu Pro 18.04 LTSvipspkg:deb/ubuntu/vips?arch=source&distro=esm-apps/bionicOther threatsAffected
  • =8.4.5-1build1
  • =8.4.5-1ubuntu0.1~esm1
  • =8.4.5-1ubuntu0.1~esm2
Fixed in–
Ubuntu Pro 16.04 LTSvipspkg:deb/ubuntu/vips?arch=source&distro=esm-apps-legacy/xenialOther threatsAffected
  • 7.40.6-2ubuntu2 – 8.2.2-1ubuntu0.1~esm1
5 affected builds
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

Description

libvips is a demand-driven, horizontally threaded image processing library. For versions 8.17.1 and below, when libvips is compiled with support for PDF input via poppler, the pdfload operation is affected by a buffer read overflow when parsing the header of a crafted PDF with a page that defines a width but not a height. Those using libvips compiled without support for PDF input are unaffected as well as thosewith support for PDF input via PDFium. This issue is fixed in version 8.17.2. A workaround for those affected is to block the VipsForeignLoadPdf operation via vips_operation_block_set, which is available in most language bindings, or to set VIPS_BLOCK_UNTRUSTED environment variable at runtime, which will block all untrusted loaders including PDF input via poppler.

References

Community reviews

Loading reviews…