Skip to main content
CVE-2026-70653VulnerabilityPublished Updated

vips · Prior to version 8.18.3, the old-style Radiance RLE decoder in libvips/foreign/radiance.c can process a repeat marker

Affects vipsSource GCVE Database

0
Compare
Authoritative record:CVE-2026-70653· Medium 4.8

Not known to be exploited · CVSS 4.8 Medium · fixed in 8.18.3 : update vips when convenient.

Data as of 3 Nov 2026, 23:17 UTC

CVSS 4.0 base score
4.8Medium
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 8.18.3
CVSS:4.0/AV:L/AC:L/AT:N/PR:L/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 20 Aug 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 3 Nov 2026.

What to do

Affected software

ProductAffectedFixed in
Ubuntu Pro 26.04 LTSvipspkg:deb/ubuntu/vips?arch=source&distro=esm-apps/resoluteOther threatsAffected
  • 8.16.1-1 – 8.18.0-1ubuntu0.1~esm2
7 affected builds
Fixed in–
Ubuntu Pro 24.04 LTSvipspkg:deb/ubuntu/vips?arch=source&distro=esm-apps/nobleOther threatsAffected
  • 8.14.3-1 – 8.15.1-1build1
10 affected builds
Fixed in–
Ubuntu Pro 22.04 LTSvipspkg:deb/ubuntu/vips?arch=source&distro=esm-apps/jammyOther threatsAffected
  • 8.10.5-2ubuntu1 – 8.12.1-1ubuntu0.1~esm3
7 affected builds
Fixed in–
Ubuntu Pro 20.04 LTSvipspkg:deb/ubuntu/vips?arch=source&distro=esm-apps/focalOther threatsAffected
  • 8.7.4-1build1 – 8.9.1-2ubuntu0.1~esm2
9 affected builds
Fixed in–
Ubuntu Pro 18.04 LTSvipspkg:deb/ubuntu/vips?arch=source&distro=esm-apps/bionicOther threatsAffected
  • =8.4.5-1build1
  • =8.4.5-1ubuntu0.1~esm1
  • =8.4.5-1ubuntu0.1~esm2
Fixed in–
Ubuntu Pro 16.04 LTSvipspkg:deb/ubuntu/vips?arch=source&distro=esm-apps-legacy/xenialOther threatsAffected
  • 7.40.6-2ubuntu2 – 8.2.2-1ubuntu0.1~esm1
5 affected builds
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

Description

libvips is a fast image processing library with low memory needs. Prior to version 8.18.3, the old-style Radiance RLE decoder in libvips/foreign/radiance.c can process a repeat marker at the beginning of a scanline in scanline_read_old and read q[-1] before any prior pixel exists. A crafted Radiance image loaded through VipsForeignLoadRad can therefore disclose four bytes of adjacent heap data, most likely other image data. This issue is fixed in version 8.18.3.

References

Community reviews

Loading reviews…