Skip to main content
CVE-2026-124316VulnerabilityPublished

Frappe ERPNext before 15.121.4 and 16.x before 16.36.0 contains a missing authorization vulnerability in the

Source GCVE Database

0
Compare
Authoritative record:CVE-2026-124316· Medium 5.3

Not known to be exploited · CVSS 5.3 Medium : upgrade to 16.36.0 or 15.121.4 when convenient.

Data as of 7 Nov 2026, 16:05 UTC

CVSS 4.0 base score
5.3Medium
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (VulnCheck)CVSS 4.05.3
CNA (VulnCheck)CVSS 3.14.3
Patch
Available – fixed in 16.36.0, 15.121.4
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 7 Nov 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 7 Nov 2026.

What to do

Upgrade erpnext to 16.36.0 or 15.121.4.

Affected software

ProductAffectedFixed in
frappeerpnextAffected
  • >=16.0.0-beta.1 <16.36.0
Fixed in
  • 16.36.0
frappeerpnextAffected
  • <15.121.4
Fixed in
  • 15.121.4
GitHuberpnextpkg:github/erpnextOther threatsAffected
  • <15.121.4
  • >=16.0.0-beta.1 <16.36.0
Fixed in
  • 15.121.4
  • 16.36.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available in Frappe ERPNext versions 15.121.4 and 16.36.0. Users should upgrade to these or later versions to remediate the vulnerability. No other mitigation steps are indicated.

Description

Frappe ERPNext versions before 15.121.4 and 16.x before 16.36.0 have a missing authorization vulnerability in the erpnext.buying.utils.get_linked_material_requests method. This flaw allows authenticated users, including portal users or users without roles, to retrieve open Purchase-type Material Requests from other companies by supplying item codes. The vulnerability arises because the method lacks proper document or company permission checks.

References

Community reviews

Loading reviews…