Skip to main content
CVE-2026-124443VulnerabilityPublished

Frappe Framework before 15.121.1 and 16.x before 16.35.0 contains a broken access control vulnerability in File list

Source GCVE Database

0
Compare
Authoritative record:CVE-2026-124443· Medium 5.3

Not known to be exploited · CVSS 5.3 Medium : upgrade to 16.35.0 when convenient.

Data as of 8 Nov 2026, 18:04 UTC

CVSS 4.0 base score
5.3Medium
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (VulnCheck)CVSS 4.05.3
CNA (VulnCheck)CVSS 3.14.3
Patch
Available – fixed in 16.35.0, 15.121.1
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 8 Nov 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 8 Nov 2026.

What to do

Upgrade frappe to 16.35.0; frappe to 15.121.1; frappe to 16.35.0 or 15.121.1.

Affected software

ProductAffectedFixed in
frappefrappeAffected
  • >=16.0.0 <16.35.0
Fixed in
  • 16.35.0
frappefrappeAffected
  • <15.121.1
Fixed in
  • 15.121.1
PyPIfrappepkg:pypi/frappeOther threatsAffected
  • >=16.0.0 <16.35.0
  • <15.121.1
Fixed in
  • 16.35.0
  • 15.121.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

The vulnerability affects Frappe Framework versions before 15.121.1 and 16.x before 16.35.0. Users should upgrade to version 15.121.1 or later, or 16.35.0 or later, where this issue is fixed. No other mitigation or workaround is indicated.

Description

Frappe Framework versions before 15.121.1 and 16.x before 16.35.0 have a broken access control vulnerability that allows authenticated users to query file list or report views and obtain metadata of private files they should not access.

References

Community reviews

Loading reviews…