Skip to main content
CVE-2026-109940VulnerabilityPublished Updated

FreeRDP 3.0.0-beta1 before 3.32.0 on Unix builds with PKCS#11 support has a stack-based buffer overflow in

Affects freerdpSource GCVE Database

0
Authoritative record:CVE-2026-109940· Medium 5.1

Not known to be exploited · CVSS 5.1 Medium · fixed in 3.32.0+dfsg-0ubuntu0.24.04.1 : update freerdp when convenient.

Data as of 28 Oct 2026, 01:30 UTC

CVSS 4.0 base score
5.1Medium
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 3.32.0+dfsg-0ubuntu0.24.04.1, 3.32.0+dfsg-0ubuntu0.26.04.1
CVSS:4.0/AV:P/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 13 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade the Ubuntu freerdp3 to 3.32.0+dfsg-0ubuntu0.24.04.1 (package) or 3.32.0+dfsg-0ubuntu0.26.04.1 (package).

Affected software

ProductAffectedFixed in
Ubuntu 26.04 LTSfreerdp3pkg:deb/ubuntu/freerdp3?arch=source&distro=resoluteOther threatsAffected
  • <3.32.0+dfsg-0ubuntu0.26.04.1
Fixed in
  • 3.32.0+dfsg-0ubuntu0.26.04.1
Ubuntu 24.04 LTSfreerdp3pkg:deb/ubuntu/freerdp3?arch=source&distro=nobleOther threatsAffected
  • <3.32.0+dfsg-0ubuntu0.24.04.1
Fixed in
  • 3.32.0+dfsg-0ubuntu0.24.04.1
Ubuntu Pro 24.04 LTSfreerdp2pkg:deb/ubuntu/freerdp2?arch=source&distro=esm-apps/nobleOther threatsAffected
  • 2.10.0+dfsg1-1.1ubuntu1 – 2.11.5+dfsg1-1ubuntu0.1~esm6
12 affected builds
Fixed in–
Ubuntu 22.04 LTSfreerdp2pkg:deb/ubuntu/freerdp2?arch=source&distro=jammyOther threatsAffected
  • 2.3.0+dfsg1-2build1 – 2.6.1+dfsg1-3ubuntu2.11
23 affected builds
Fixed in–
Ubuntu Pro 20.04 LTSfreerdp2pkg:deb/ubuntu/freerdp2?arch=source&distro=esm-infra/focalOther threatsAffected
  • 2.0.0~git20190204.1.2693389a+dfsg1-1 – 2.6.1+dfsg1-0ubuntu0.20.04.2+esm4
17 affected builds
Fixed in–
Ubuntu Pro 18.04 LTSfreerdp2pkg:deb/ubuntu/freerdp2?arch=source&distro=esm-infra/bionicOther threatsAffected
  • 2.0.0~git20170725.1.1648deb+dfsg1-1 – 2.2.0+dfsg1-0ubuntu0.18.04.4+esm6
19 affected builds
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available and fixed versions include 3.32.0+dfsg-0ubuntu0.24.04.1 and 3.32.0+dfsg-0ubuntu0.26.04.1. Users should upgrade to these or later versions to remediate the vulnerability. No additional mitigation steps are indicated.

Description

FreeRDP versions before 3.32.0 on Unix systems with PKCS#11 support contain a stack-based buffer overflow vulnerability in the wprintKeyName() function of WinPR's NCrypt PKCS#11 provider. The flaw arises when hex-encoding a key's CKA_ID of up to 64 bytes into a fixed 128-byte stack buffer, allowing an attacker to overflow the stack by supplying a malicious PKCS#11 token or module with a 55- to 64-byte CKA_ID during key enumeration, causing a client crash.

References

Community reviews

Loading reviews…