Skip to main content
CVE-2026-121962VulnerabilityPublished Updated

FreeRDP before 3.32.2 contains a heap buffer overflow in transport_default_read_pdu when handling partial Early User

Affects freerdpSource GCVE Database

0
Compare
Authoritative record:CVE-2026-121962· High 7.2

Not known to be exploited · CVSS 7.2 High · fixed in 3.32.2 : patch freerdp soon.

Data as of 6 Nov 2026, 05:03 UTC

CVSS 4.0 base score
7.2High
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (VulnCheck)CVSS 4.07.2
CNA (VulnCheck)CVSS 3.18.1
Patch
Available – fixed in 3.32.2
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:H/VA:H/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 4 Nov 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.

What to do

Affected software

ProductAffectedFixed in
Ubuntu 18.04 LTSfreerdppkg:deb/ubuntu/freerdp?arch=source&distro=bionicOther threatsAffected
  • =1.1.0~git20140921.1.440916e+dfsg1-15ubuntu1
  • =1.1.0~git20140921.1.440916e+dfsg1-15ubuntu1.18.04.1
  • =1.1.0~git20140921.1.440916e+dfsg1-15ubuntu1.18.04.2
Fixed in–
Ubuntu 16.04 LTSfreerdppkg:deb/ubuntu/freerdp?arch=source&distro=xenialOther threatsAffected
  • 1.1.0~git20140921.1.440916e+dfsg1-5ubuntu1 – 1.1.0~git20140921.1.440916e+dfsg1-5ubuntu1.4
4 affected builds
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available in FreeRDP version 3.32.2 and later. Users and administrators should upgrade to version 3.32.2 or newer to remediate this vulnerability. No other mitigation or workaround is indicated in the provided data.

Description

FreeRDP versions prior to 3.32.2 contain a heap buffer overflow vulnerability in the transport_default_read_pdu function. This occurs during handling of partial Early User Authorization (EUA) reads in the PROTOCOL_HYBRID_EX CredSSP protocol. A malicious RDP server can exploit this by splitting the four-byte EUA result into short reads, causing the stream pointer to advance beyond the allocated 16 KiB buffer, resulting in an out-of-bounds write and client denial of service.

References

Community reviews

Loading reviews…