Skip to main content
CVE-2026-121952VulnerabilityPublished

FreeRDP before 3.32.2 has an out-of-bounds write in the proxy because rdp_read_bitmap_cache_v2_capability_set rejects

Source GCVE Database

0
Compare
Authoritative record:CVE-2026-121952· Critical 9.3

Not known to be exploited · CVSS 9.3 Critical : upgrade to 3.32.2 as a priority.

Data as of 4 Nov 2026, 19:58 UTC

CVSS 4.0 base score
9.3Critical
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (VulnCheck)CVSS 4.09.3
CNA (VulnCheck)CVSS 3.19.8
Patch
Available – fixed in 3.32.2
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 4 Nov 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 4 Nov 2026.

What to do

Upgrade FreeRDP and freerdp/FreeRDP to 3.32.2.

Affected software

ProductAffectedFixed in
FreeRDPFreeRDPAffected
  • <3.32.2
Fixed in
  • 3.32.2
GitHubfreerdp/FreeRDPpkg:github/freerdp/FreeRDPOther threatsAffected
  • <3.32.2
Fixed in
  • 3.32.2

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available in FreeRDP version 3.32.2 and later. Users should upgrade to version 3.32.2 or newer to remediate this vulnerability. No other mitigation or workaround is indicated.

Description

FreeRDP versions prior to 3.32.2 contain an out-of-bounds write vulnerability in the proxy component. This occurs because the function rdp_read_bitmap_cache_v2_capability_set only rejects numCellCaches values above 5, but later accesses fixed indices 0 through 4 regardless. A client connecting to the proxy can declare fewer than five cell caches, leading to heap corruption, potential data leakage, or a crash.

References

Community reviews

Loading reviews…