Skip to main content
VulnerabilityPublished Updated

CVE-2026-55564: libfreerdp/cache/glyph.c checks whether index · Prior to 3.27.0, the glyph_cache_get function

Affects freerdpSource GCVE Database

0
Compare
Authoritative record:CVE-2026-55564· Medium 5.4

Not known to be exploited · CVSS 5.4 Medium · fixed in 3.30.0+dfsg-0ubuntu0.24.04.1 : update freerdp when convenient.

Data as of 30 Oct 2026, 06:59 UTC

CVSS 3.1 base score
5.4Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.3% chance of exploitation in 30 days – higher than 25% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 3.30.0+dfsg-0ubuntu0.24.04.1, 3.30.0+dfsg-0ubuntu0.26.04.1
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:N/A:L

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 19 Aug 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade the Ubuntu freerdp3 to 3.30.0+dfsg-0ubuntu0.24.04.1 (package) or 3.30.0+dfsg-0ubuntu0.26.04.1 (package).

Affected software

ProductAffectedFixed in
Ubuntu 26.04 LTSfreerdp3pkg:deb/ubuntu/freerdp3?arch=source&distro=resoluteOther threatsAffected
  • <3.30.0+dfsg-0ubuntu0.26.04.1
Fixed in
  • 3.30.0+dfsg-0ubuntu0.26.04.1
Ubuntu 25.10freerdp3pkg:deb/ubuntu/freerdp3?arch=source&distro=questingOther threatsAffected
  • 3.14.0+dfsg-1ubuntu1 – 3.16.0+dfsg-2ubuntu0.5
8 affected builds
Fixed in–
Ubuntu 24.04 LTSfreerdp3pkg:deb/ubuntu/freerdp3?arch=source&distro=nobleOther threatsAffected
  • <3.30.0+dfsg-0ubuntu0.24.04.1
Fixed in
  • 3.30.0+dfsg-0ubuntu0.24.04.1
Ubuntu Pro 24.04 LTSfreerdp2pkg:deb/ubuntu/freerdp2?arch=source&distro=esm-apps/nobleOther threatsAffected
  • 2.10.0+dfsg1-1.1ubuntu1 – 2.11.5+dfsg1-1ubuntu0.1~esm6
12 affected builds
Fixed in–
Ubuntu 22.04 LTSfreerdp2pkg:deb/ubuntu/freerdp2?arch=source&distro=jammyOther threatsAffected
  • 2.3.0+dfsg1-2build1 – 2.6.1+dfsg1-3ubuntu2.11
23 affected builds
Fixed in–
Ubuntu Pro 20.04 LTSfreerdp2pkg:deb/ubuntu/freerdp2?arch=source&distro=esm-infra/focalOther threatsAffected
  • 2.0.0~git20190204.1.2693389a+dfsg1-1 – 2.6.1+dfsg1-0ubuntu0.20.04.2+esm4
17 affected builds
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available that fixes this vulnerability in FreeRDP version 3.27.0. Users and administrators should update to version 3.27.0 or later to remediate this issue. Standard system updates on supported Ubuntu releases will apply the necessary fixes. No additional mitigations are required once the update is applied.

Description

FreeRDP versions prior to 3.27.0 contain a vulnerability in the glyph_cache_get function where an off-by-one error allows reading beyond the bounds of an array. This flaw can be triggered by a malicious RDP server causing the client to dereference memory adjacent to the glyph cache, potentially leading to a crash and limited disclosure of adjacent heap data. The issue is fixed in FreeRDP version 3.27.0.

References

Community reviews

Loading reviews…