Skip to main content
VulnerabilityPublished Updated

CVE-2026-23948: freerdp2, freerdp3 vulnerabilities

Affects freerdp2Source GCVE Database

0

Mentioned vulnerabilities

Not known to be exploited : upgrade to 2.2.0+dfsg1-0ubuntu0.18.04.4+esm5 soon.

Data as of 26 Oct 2026, 09:08 UTC

Severity
High

Rated by Threat Radar · No CVSS score from NVD or the CNA

EPSS
0.5% chance of exploitation in 30 days – higher than 44% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2.2.0+dfsg1-0ubuntu0.18.04.4+esm5, 2.6.1+dfsg1-0ubuntu0.20.04.2+esm3, 2.6.1+dfsg1-3ubuntu2.10 +3

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 16 Feb 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade to a fixed release listed under Affected software.

Affected software

ProductAffectedFixed in
Ubuntu:Pro:18.04:LTSfreerdp2pkg:deb/ubuntu/freerdp2?arch=source&distro=esm-infra/bionicOther threatsAffected
  • <2.2.0+dfsg1-0ubuntu0.18.04.4+esm5
  • =2.0.0~git20170725.1.1648deb+dfsg1-1
  • =2.0.0~git20170725.1.1648deb+dfsg1-5
  • =2.0.0~git20170725.1.1648deb+dfsg1-5ubuntu1
  • =2.0.0~git20170725.1.1648deb+dfsg1-5ubuntu2
  • =2.0.0~git20170725.1.1648deb+dfsg1-6
  • =2.0.0~git20170725.1.1648deb+dfsg1-6build1
  • =2.0.0~git20170725.1.1648deb+dfsg1-7
  • =2.0.0~git20170725.1.1648deb+dfsg1-7ubuntu0.1
  • =2.1.1+dfsg1-0ubuntu0.18.04.1
  • =2.2.0+dfsg1-0ubuntu0.18.04.1
  • =2.2.0+dfsg1-0ubuntu0.18.04.2
  • =2.2.0+dfsg1-0ubuntu0.18.04.3
  • =2.2.0+dfsg1-0ubuntu0.18.04.4
  • =2.2.0+dfsg1-0ubuntu0.18.04.4+esm1
  • =2.2.0+dfsg1-0ubuntu0.18.04.4+esm2
  • =2.2.0+dfsg1-0ubuntu0.18.04.4+esm3
  • =2.2.0+dfsg1-0ubuntu0.18.04.4+esm4
Fixed in
  • 2.2.0+dfsg1-0ubuntu0.18.04.4+esm5
Ubuntu:Pro:20.04:LTSfreerdp2pkg:deb/ubuntu/freerdp2?arch=source&distro=esm-infra/focalOther threatsAffected
  • <2.6.1+dfsg1-0ubuntu0.20.04.2+esm3
  • =2.0.0~git20190204.1.2693389a+dfsg1-1
  • =2.0.0~git20190204.1.2693389a+dfsg1-2
  • =2.0.0~git20190204.1.2693389a+dfsg1-2build1
  • =2.0.0~git20190204.1.2693389a+dfsg1-2build2
  • =2.1.1+dfsg1-0ubuntu0.20.04.1
  • =2.2.0+dfsg1-0ubuntu0.20.04.1
  • =2.2.0+dfsg1-0ubuntu0.20.04.2
  • =2.2.0+dfsg1-0ubuntu0.20.04.3
  • =2.2.0+dfsg1-0ubuntu0.20.04.4
  • =2.2.0+dfsg1-0ubuntu0.20.04.5
  • =2.2.0+dfsg1-0ubuntu0.20.04.6
  • =2.6.1+dfsg1-0ubuntu0.20.04.1
  • =2.6.1+dfsg1-0ubuntu0.20.04.2
  • =2.6.1+dfsg1-0ubuntu0.20.04.2+esm1
  • =2.6.1+dfsg1-0ubuntu0.20.04.2+esm2
Fixed in
  • 2.6.1+dfsg1-0ubuntu0.20.04.2+esm3
Ubuntu:22.04:LTSfreerdp2pkg:deb/ubuntu/freerdp2?arch=source&distro=jammyOther threatsAffected
  • <2.6.1+dfsg1-3ubuntu2.10
  • =2.3.0+dfsg1-2build1
  • =2.3.0+dfsg1-2ubuntu1
  • =2.3.0+dfsg1-2ubuntu2
  • =2.4.1+dfsg1-1
  • =2.4.1+dfsg1-1ubuntu1
  • =2.4.1+dfsg1-1ubuntu2
  • =2.5.0+dfsg1-1
  • =2.6.0+dfsg1-1
  • =2.6.1+dfsg1-1
  • =2.6.1+dfsg1-3
  • =2.6.1+dfsg1-3ubuntu1
  • =2.6.1+dfsg1-3ubuntu2
  • =2.6.1+dfsg1-3ubuntu2.1
  • =2.6.1+dfsg1-3ubuntu2.2
  • =2.6.1+dfsg1-3ubuntu2.3
  • =2.6.1+dfsg1-3ubuntu2.4
  • =2.6.1+dfsg1-3ubuntu2.5
  • =2.6.1+dfsg1-3ubuntu2.6
  • =2.6.1+dfsg1-3ubuntu2.7
  • =2.6.1+dfsg1-3ubuntu2.8
  • =2.6.1+dfsg1-3ubuntu2.9
Fixed in
  • 2.6.1+dfsg1-3ubuntu2.10
Ubuntu:24.04:LTSfreerdp3pkg:deb/ubuntu/freerdp3?arch=source&distro=nobleOther threatsAffected
  • <3.5.1+dfsg1-0ubuntu1.2
  • =3.4.0+dfsg1-0ubuntu2
  • =3.4.0+dfsg1-0ubuntu3
  • =3.4.0+dfsg1-0ubuntu4
  • =3.5.0+dfsg1-0ubuntu1
  • =3.5.1+dfsg1-0ubuntu1
  • =3.5.1+dfsg1-0ubuntu1.1
Fixed in
  • 3.5.1+dfsg1-0ubuntu1.2
Ubuntu:Pro:24.04:LTSfreerdp2pkg:deb/ubuntu/freerdp2?arch=source&distro=esm-apps/nobleOther threatsAffected
  • <2.11.5+dfsg1-1ubuntu0.1~esm5
  • =2.10.0+dfsg1-1.1ubuntu1
  • =2.11.2+dfsg1-1
  • =2.11.2+dfsg1-1build1
  • =2.11.2+dfsg1-1build3
  • =2.11.5+dfsg1-1build1
  • =2.11.5+dfsg1-1build2
  • =2.11.5+dfsg1-1ubuntu0.1~esm1
  • =2.11.5+dfsg1-1ubuntu0.1~esm2
  • =2.11.5+dfsg1-1ubuntu0.1~esm3
  • =2.11.5+dfsg1-1ubuntu0.1~esm4
Fixed in
  • 2.11.5+dfsg1-1ubuntu0.1~esm5
Ubuntu:25.10freerdp3pkg:deb/ubuntu/freerdp3?arch=source&distro=questingOther threatsAffected
  • <3.16.0+dfsg-2ubuntu0.1
  • =3.14.0+dfsg-1ubuntu1
  • =3.15.0+dfsg-2.1
  • =3.16.0+dfsg-1ubuntu1
  • =3.16.0+dfsg-2
Fixed in
  • 3.16.0+dfsg-2ubuntu0.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Official patches are available and should be applied promptly. Ubuntu has released updated package versions fixing these vulnerabilities for all affected releases, including Ubuntu 18.04 LTS, 20.04 LTS, 22.04 LTS, 24.04 LTS, and 25.10. Users should update FreeRDP packages via standard system updates or through Ubuntu Pro and ESM services where applicable. No additional mitigation steps are indicated beyond applying these updates.

Description

Multiple vulnerabilities were identified in FreeRDP versions used in various Ubuntu releases, including memory handling errors, buffer overflows, and use-after-free conditions. These issues could allow attackers to cause denial of service or potentially execute arbitrary code. The vulnerabilities affect FreeRDP2 and FreeRDP3 packages across Ubuntu 18.04 LTS, 20.04 LTS, 22.04 LTS, 24.04 LTS, and 25.10. Official patches are available from Ubuntu, including updates distributed via Ubuntu Pro and Extended Security Maintenance (ESM).

References

Community reviews

Loading reviews…