Skip to main content
VulnerabilityPublished

CVE-2026-59973: FrontMCP and mcp-from-openapi have bypass of OpenAPI external $ref SSRF fix

Affects mcp-from-openapiSource GCVE Database

0
Authoritative record:CVE-2026-59973· High 8.5

Not known to be exploited · CVSS 8.5 High : upgrade to 2.5.0 soon.

Data as of 27 Oct 2026, 05:11 UTC

CVSS 3.1 base score
8.5High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.3% chance of exploitation in 30 days – higher than 33% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2.5.0, 1.5.0
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:L/A:N

Exploitation evidence

t = 0 is the CVE’s publication on cve.org

  1. Disclosed: evidence found.

    CVE published 15 Sep 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: evidence found.

    CISA SSVC: proof of concept public

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

Timeline

  1. CVE ID reserved

    by GitHub, Inc.

    , 70 days before disclosure

  2. CVE published

    on cve.org

    , t = 0

  3. CISA SSVC assessment

    proof of concept public

    , 25 hours after disclosure

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), CISA SSVC, the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade mcp-from-openapi to 2.5.0; @frontmcp/adapters and frontmcp to 1.5.0.

Affected software

ProductAffectedFixed in
npmmcp-from-openapiAffected
  • >=2.3.0 <2.5.0
Fixed in
  • 2.5.0
npm@frontmcp/adaptersAffected
  • >=1.2.1 <1.5.0
Fixed in
  • 1.5.0
npmfrontmcpAffected
  • >=1.2.1 <1.5.0
Fixed in
  • 1.5.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available for this vulnerability. Users should upgrade mcp-from-openapi to a fixed version beyond 2.3.0 and FrontMCP to versions beyond 1.2.1 that update this dependency and improve the SSRF protections. Until patched, avoid loading untrusted OpenAPI specifications that may contain external $ref references. The vendor advisory confirms a fix is available; apply official updates accordingly.

Description

FrontMCP is a TypeScript-first framework for the Model Context Protocol (MCP). From mcp-from-openapi 2.3.0 until 2.5.0 and from frontmcp and @frontmcp/adapters 1.2.1 until 1.5.0, libs/adapters/src/openapi/openapi.adapter.ts loadOpenAPISpec() forwards untrusted OpenAPI url and spec inputs and loadOptions.refResolution to OpenAPIToolGenerator.fromURL() and OpenAPIToolGenerator.fromJSON(). The external $ref guard checks parsed hostname strings without resolving addresses, pinning validated addresses, revalidating redirect targets, or normalizing IPv4-mapped IPv6. An authenticated user who can import or configure an OpenAPI specification in a hosted or multi-user deployment can use DNS-to-loopback resolution, redirect-to-loopback behavior, or IPv4-mapped IPv6 loopback forms to cause backend-origin requests to internal services. This can expose internal administrative APIs, metadata-like services, and other private network endpoints. The practical impact is lower when only a trusted local administrator can configure OpenAPI specs, and disabling external reference protocols prevents the external $ref request. This issue is fixed in mcp-from-openapi 2.5.0 and frontmcp and @frontmcp/adapters 1.5.0.

References

Community reviews

Loading reviews…