Skip to main content
CVE-2026-121434VulnerabilityPublished

Froxlor 2.3.0 before 2.3.15 contains a missing authorization check in the Certificates.add and Certificates.update API

Affects froxlorSource GCVE Database

0
Compare
Authoritative record:CVE-2026-121434· Medium 5.3

Not known to be exploited · CVSS 5.3 Medium : upgrade to 2.3.15 when convenient.

Data as of 3 Nov 2026, 16:28 UTC

CVSS 4.0 base score
5.3Medium
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (VulnCheck)CVSS 4.05.3
CNA (VulnCheck)CVSS 3.15.4
Patch
Available – fixed in 2.3.15
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:L/VA:L/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 3 Nov 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 3 Nov 2026.

What to do

Upgrade froxlor/froxlor to 2.3.15.

Affected software

ProductAffectedFixed in
GitHubfroxlor/froxlorpkg:github/froxlor/froxlorOther threatsAffected
  • =2.3.0 <2.3.15
Fixed in
  • 2.3.15

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available in Froxlor version 2.3.15. Users should upgrade to version 2.3.15 or later to address this missing authorization check vulnerability. No other mitigation or temporary workaround is indicated.

Description

Froxlor versions from 2.3.0 up to but not including 2.3.15 have a missing authorization check vulnerability in the Certificates.add and Certificates.update API commands. This flaw allows customers with API access to overwrite Let's Encrypt-managed certificates and private keys with attacker-chosen values. The overwritten certificates are then deployed to the webserver by a REBUILD_VHOST task, disrupting HTTPS functionality and desynchronizing ACME automation.

References

Community reviews

Loading reviews…