CVE-2026-121434: froxlor · Missing Authorization
Affects froxlorSource CVE Database V5
Not known to be exploited · CVSS 5.3 Medium : upgrade to 2.3.15 when convenient.
Data as of 3 Nov 2026, 14:58 UTC
Thin evidence
One scorer or none| CNA (VulnCheck) | CVSS 4.0 | 5.3 |
|---|---|---|
| CNA (VulnCheck) | CVSS 3.1 | 5.4 |
- Patch
- Available – fixed in 2.3.15
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:L/VA:L/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 3 Nov 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 3 Nov 2026.
What to do
Upgrade froxlor and froxlor/froxlor to 2.3.15.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| froxlorfroxlor | Affected
| Fixed in
|
GitHubfroxlor/froxlorpkg:github/froxlor/froxlorOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade Froxlor to version 2.3.15 or later, where the missing authorization checks have been fixed. No other mitigation is indicated or required.
Description
Froxlor versions 2.3.0 through 2.3.14 have a missing authorization check vulnerability in the Certificates.add and Certificates.update API commands. This flaw allows customers with API access to overwrite Let's Encrypt-managed certificates and private keys with attacker-chosen ones. The altered certificates are deployed to the webserver by a REBUILD_VHOST task, disrupting HTTPS and desynchronizing ACME automation.