Skip to main content
VulnerabilityPublished Updated

CVE-2025-34490: GFI MailEssentials prior to version 21.8 is vulnerable to an XML External Entity (XXE) issue

Source GCVE Database

0
Compare

Not known to be exploited · CVSS 6.5 Medium · fixed in 21.8 : update affected systems when convenient.

Data as of 4 Nov 2026, 17:52 UTC

CVSS 3.1 base score
6.5Medium
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 21.8
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 28 Apr 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 4 Nov 2026.

What to do

AI-suggested

Upgrade GFI MailEssentials to version 21.8 or later to remediate this vulnerability. Since the vulnerability affects versions prior to 21.8, applying this official fix will mitigate the issue. No other mitigation or temporary workaround is indicated.

Description

GFI MailEssentials versions prior to 21.8 contain an XML External Entity (XXE) vulnerability that allows an authenticated remote attacker to send crafted HTTP requests to read arbitrary system files. This vulnerability can lead to unauthorized disclosure of sensitive information. The issue is identified as CVE-2025-34490 and has a CVSS 3.1 base score of 6.5, indicating a medium severity level.

References

Community reviews

Loading reviews…