Skip to main content
VulnerabilityPublished Updated

CVE-2025-54988: Org.apache.tika:tika parser pdf module: Apache Tika XXE Vulnerability via Crafted XFA File Inside a PDF

Affects org.apache.tika:tika-parser-pdf-moduleSource GCVE Database

0
Compare
Authoritative record:CVE-2025-54988· High 8.4

Not known to be exploited · public detection template (Nuclei) · CVSS 8.4 High : upgrade to 3.2.2 soon.

Data as of 4 Nov 2026, 18:16 UTC

CVSS 3.1 base score
8.4High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 3.2.2, 2.0.0-ALPHA
CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 20 Aug 2025

  2. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  3. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 4 Nov 2026.

What to do

Upgrade org.apache.tika:tika-parser-pdf-module to 3.2.2; org.apache.tika:tika-parsers to 2.0.0-ALPHA.

Affected software

ProductAffectedFixed in
Mavenorg.apache.tika:tika-parser-pdf-moduleAffected
  • >=1.13 <3.2.2
Fixed in
  • 3.2.2
Mavenorg.apache.tika:tika-parsersAffected
  • >=1.13 <2.0.0-ALPHA
Fixed in
  • 2.0.0-ALPHA

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Users should upgrade affected Apache Tika packages to version 3.2.2 or 2.0.0-ALPHA, where this vulnerability is fixed. No other mitigation or temporary workaround is indicated. Applying the official patch is the recommended remediation.

Description

A critical XML External Entity (XXE) vulnerability exists in Apache Tika's tika-parser-pdf-module versions 1.13 through 3.2.1. This flaw allows attackers to exploit crafted XFA files inside PDFs to perform XXE injection, potentially leading to sensitive data disclosure or malicious requests to internal or external servers. The vulnerability affects multiple Tika packages that depend on this module. Upgrading to version 3.2.2 or 2.0.0-ALPHA resolves the issue.

References

Community reviews

Loading reviews…