Skip to main content
VulnerabilityPublished Updated

CVE-2025-54988: Apache Tika PDF parser module · XML External Entity (XXE)

Affects Apache Tika PDF parser moduleSource CVE Database V5

0

Public exploit available (Metasploit) · 47% EPSS · CVSS 8.4 High · fixed in 3.2.2 : patch Apache Tika PDF parser module as a priority.

Data as of 26 Oct 2026, 14:05 UTC

CVSS 3.1 base score
8.4High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
47.9% chance of exploitation in 30 days – higher than 98% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 3.2.2
CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 20 Aug 2025

  2. Weaponised: evidence found.

    1 Metasploit module

  3. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  4. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Affected software

ProductAffectedFixed in
Apache Software Foundation Apache Tika PDF parser moduleAffected
  • =1.13
Fixed in–

AI-suggested

A fix is available in Apache Tika version 3.2.2. Users and administrators should upgrade affected Apache Tika installations to version 3.2.2 or later to remediate this vulnerability. Since this is not a cloud service, remediation depends on applying the official patch. No additional vendor advisory content is provided, so check the Apache Software Foundation's official security advisories for the latest updates and guidance.

Description

CVE-2025-54988 is a high-severity XML External Entity (XXE) vulnerability in the Apache Tika PDF parser module affecting versions 1.13 through 3.2.1. It allows attackers to inject malicious XML entities via crafted XFA files inside PDFs, potentially enabling unauthorized reading of sensitive data or triggering malicious requests to internal or external resources. The vulnerability impacts multiple Tika packages that depend on the vulnerable PDF parser module. Users are advised to upgrade to Apache Tika version 3.2.2, which addresses this issue.

References

Community reviews

Loading reviews…