Org.apache.jackrabbit:jackrabbit spi commons: Apache Jackrabbit vulnerable to blind XXE attack due to insecure
Affects org.apache.jackrabbit:jackrabbit-spi-commonsSource GCVE Database
Not known to be exploited · CVSS 8.8 High : upgrade to 2.20.17 soon.
Data as of 4 Nov 2026, 18:15 UTC
Thin evidence
One scorer or none| CISA-ADP | CVSS 3.1 | 8.8 |
|---|
- Patch
- Available – fixed in 2.20.17, 2.22.1, 2.23.2-beta
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 14 Jul 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 4 Nov 2026.
What to do
Upgrade org.apache.jackrabbit:jackrabbit-spi-commons and org.apache.jackrabbit:jackrabbit-core to 2.20.17; org.apache.jackrabbit:jackrabbit-spi-commons and org.apache.jackrabbit:jackrabbit-core to 2.22.1; org.apache.jackrabbit:jackrabbit-spi-commons and org.apache.jackrabbit:jackrabbit-core to 2.23.2-beta.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Mavenorg.apache.jackrabbit:jackrabbit-spi-commons | Affected
| Fixed in
|
| Mavenorg.apache.jackrabbit:jackrabbit-spi-commons | Affected
| Fixed in
|
| Mavenorg.apache.jackrabbit:jackrabbit-spi-commons | Affected
| Fixed in
|
| Mavenorg.apache.jackrabbit:jackrabbit-core | Affected
| Fixed in
|
| Mavenorg.apache.jackrabbit:jackrabbit-core | Affected
| Fixed in
|
| Mavenorg.apache.jackrabbit:jackrabbit-core | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch is available and users should upgrade to Apache Jackrabbit versions 2.20.17 (Java 8), 2.22.1 (Java 11), or 2.23.2-beta (Java 11 beta) which address this vulnerability. Earlier versions, including those up to 2.20.16, are no longer supported and should be updated promptly to the fixed releases.
Description
Apache Jackrabbit versions prior to 2.20.17, 2.22.1, and 2.23.2-beta contain a blind XML External Entity (XXE) vulnerability in the jackrabbit-spi-commons and jackrabbit-core components. This vulnerability arises from the use of an insecure document builder to load privileges. It allows an attacker with low privileges to cause high impact including confidentiality, integrity, and availability compromise. Users are advised to upgrade to the fixed versions to mitigate this issue.
References
- nvd.nist.gov/vuln/detail/CVE-2025-53689 (opens in a new tab)
- github.com/apache/jackrabbit/pull/263/commits/02786c0a01838580252bdab79bfa54026c30294e (opens in a new tab)
- github.com/apache/jackrabbit (opens in a new tab)
- lists.apache.org/thread/5pf9n76ny13pzzk765og2h3gxdxw7p24 (opens in a new tab)
- openwall.com/lists/oss-security/2025/07/14/1 (opens in a new tab)