Skip to main content
VulnerabilityPublished

CVE-2026-56755: Gitea · Denial of Service (CPU & Memory Exhaustion) via O(N^2) String Concatenation in Debian Package Upload

Affects code.gitea.io/giteaSource GCVE Database

0
Compare
Authoritative record:CVE-2026-56755· Medium 6.2

Not known to be exploited · CVSS 6.2 Medium : upgrade to 1.27.0 when convenient.

Data as of 30 Oct 2026, 06:59 UTC

CVSS 3.1 base score
6.2Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.1% chance of exploitation in 30 days – higher than 6% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.27.0
CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Exploitation evidence

t = 0 is the CVE’s publication on cve.org

  1. Disclosed: evidence found.

    CVE published 13 Aug 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: evidence found.

    CISA SSVC: proof of concept public

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

Timeline

  1. CVE ID reserved

    by Gitea Limited

    , 36 days before disclosure

  2. CVE published

    on cve.org

    , t = 0

  3. CISA SSVC assessment

    proof of concept public

    , 2 hours after disclosure

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), CISA SSVC, the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade code.gitea.io/gitea to 1.27.0.

Affected software

ProductAffectedFixed in
Gocode.gitea.io/giteaAffected
  • <1.27.0
Fixed in
  • 1.27.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available for this vulnerability in Gitea version 1.27.0 and later. Users should upgrade to version 1.27.0 or newer to remediate this issue. Since this is not a cloud service, administrators must apply the update themselves to mitigate the risk.

Description

Gitea versions prior to 1.27.0 contain a denial of service vulnerability in the Debian package registry parser. This flaw allows authenticated users with write access to upload malicious .deb packages that trigger excessive memory consumption through unbounded decompression. Additionally, inefficient O(N²) string concatenation in the parser causes high CPU usage, potentially stalling the server. The vulnerability can be exploited by any authenticated user with write permissions to the package registry.

References

Community reviews

Loading reviews…