Skip to main content
CVE-2026-89078VulnerabilityPublished Updated

GitLab CE/EE affecting all · GitLab Has Remediated an Issue

Affects gitlabSource GCVE Database

0
Compare
Authoritative record:CVE-2026-89078· Critical 9.9

Not known to be exploited · CVSS 9.9 Critical · fixed in 19.4.1 : patch gitlab as a priority.

Data as of 31 Oct 2026, 01:38 UTC

CVSS 3.1 base score
9.9Critical
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (GitLab)CVSS 3.19.9
Patch
Available – fixed in 19.4.1, 19.3.3, 19.2.7
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:L

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 23 Sep 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade gitlab to 19.4.1, 19.3.3 or 19.2.7.

Affected software

ProductAffectedFixed in
RubyGemsgitlabpkg:gem/gitlabOther threatsAffected
  • >=19.2 <19.2.7
  • >=19.3 <19.3.3
  • >=19.4 <19.4.1
Fixed in
  • 19.2.7
  • 19.3.3
  • 19.4.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade affected GitLab CE/EE instances to versions 19.2.7, 19.3.3, or 19.4.1 or later, where the vulnerability has been fixed. No other mitigation or workaround is indicated by the vendor advisory.

Description

A critical vulnerability (CVE-2026-89078) in GitLab CE/EE versions from 19.2 before 19.2.7, 19.3 before 19.3.3, and 19.4 before 19.4.1 could allow an authenticated user to execute arbitrary code on the GitLab server. The issue arises from a double free error when parsing a specially crafted regular expression in a CI/CD configuration. GitLab has remediated this vulnerability in versions 19.2.7, 19.3.3, and 19.4.1.

References

Community reviews

Loading reviews…