CVE-2026-89078: GitLab · Double Free
Affects GitLabSource CVE Database V5
Not known to be exploited · CVSS 9.9 Critical · fixed in 19.4.1 : patch GitLab as a priority.
Data as of 30 Oct 2026, 23:51 UTC
Thin evidence
One scorer or none| CNA (GitLab) | CVSS 3.1 | 9.9 |
|---|
- CISA SSVC
- Exploitation
- No evidence of active exploitation and no public proof of concept
- Automatable
- Attackers cannot reliably automate steps 1–4 of the kill chain
- Technical impact
- Total control over the software or total information disclosure
CISA SSVC assessment, 2026-09-24.
- Patch
- Available – fixed in 19.4.1, 19.3.3, 19.2.7
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:LExploitation evidence
Disclosed: evidence found.
CVE published 23 Sep 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade GitLab and gitlab to 19.4.1, 19.3.3 or 19.2.7.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| GitLabGitLab | Affected
| Fixed in
|
| GitLabGitLab | Affected
| Fixed in
|
| GitLabGitLab | Affected
| Fixed in
|
RubyGemsgitlabpkg:gem/gitlabOther threats | Affected
| Fixed in
|
CPE configurations (1)
cpe:2.3:a:gitlab:gitlab:*:*:*:*:*:*:*:*
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade affected GitLab CE/EE instances to versions 19.2.7, 19.3.3, or 19.4.1 or later. These versions contain the official fix for the double free vulnerability. No other mitigation is indicated or required once patched.
Description
CVE-2026-89078 is a critical double free vulnerability in GitLab CE/EE versions from 19.2 before 19.2.7, 19.3 before 19.3.3, and 19.4 before 19.4.1. It allows an authenticated user to execute arbitrary code on the GitLab server by exploiting a flaw in parsing specially crafted regular expressions in CI/CD configurations. The issue has been fixed in versions 19.2.7, 19.3.3, and 19.4.1.