nbdime · GitPython: Arbitrary file overwrite via git diff --output argument injection in Diffable.diff (key- and
Affects nbdimeSource GCVE Database
Not known to be exploited · CVSS 7.2 High : upgrade to 4.0.4_5 soon.
Data as of 26 Oct 2026, 17:26 UTC
- EPSS
- 0.5% chance of exploitation in 30 days – higher than 45% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 4.0.4_5
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:H/VA:H/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 13 Aug 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade nbdime to 4.0.4_5.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Homebrewnbdimepkg:brew/nbdimeOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch is available in GitPython version 4.0.4_5 that adds validation to prevent unsafe option injection in Diffable.diff(). Users should upgrade to this fixed version. The fix includes adding a check_unsafe_options guard and placing '--end-of-options' before user-supplied refs to block injection of '--output' or similar options. No additional mitigation is required once patched.
Description
GitPython's Diffable.diff() method improperly forwards user-supplied arguments directly to git diff commands without validating unsafe options. This allows an attacker to inject the '--output' argument, causing git to overwrite arbitrary files with diff content at the process privilege level. The vulnerability affects versions up to 3.1.53 and has been fixed in version 4.0.4_5.
References
- github.com/gitpython-developers/GitPython/security/advisories/GHSA-fjr4-x663-mwxc (opens in a new tab)
- github.com/gitpython-developers/GitPython/pull/2180 (opens in a new tab)
- github.com/gitpython-developers/GitPython/commit/1d51b891d7f236044a6aa17498ec682b63dad6e6 (opens in a new tab)
- github.com/gitpython-developers/GitPython (opens in a new tab)
- github.com/gitpython-developers/GitPython/releases/tag/3.1.54 (opens in a new tab)