Skip to main content
CVE-2026-78675VulnerabilityPublished Updated

nbdime · GitPython: Arbitrary local file content disclosure via [include] directive in untrusted .gitmodules

Affects nbdimeSource GCVE Database

0
Authoritative record:CVE-2026-78675· High 8.6

Not known to be exploited · CVSS 8.6 High : upgrade to 4.0.4_8 soon.

Data as of 26 Oct 2026, 17:28 UTC

CVSS 4.0 base score
8.6High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.1% chance of exploitation in 30 days – higher than 7% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 4.0.4_8
CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 25 Aug 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade nbdime to 4.0.4_8.

Affected software

ProductAffectedFixed in
Homebrewnbdimepkg:brew/nbdimeOther threatsAffected
  • >=1.1.0 <4.0.4_8
Fixed in
  • 4.0.4_8

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available in GitPython version 4.0.4_8 which disables merge_includes when parsing .gitmodules to prevent following arbitrary include directives. Users should upgrade to version 4.0.4_8 or later. Until upgraded, avoid processing untrusted repositories with GitPython or handle exceptions from repo.submodules carefully to avoid leaking file contents.

Description

GitPython versions from 1.1.0 up to but not including 4.0.4_8 contain a vulnerability where the SubmoduleConfigParser used to parse the .gitmodules file follows [include] directives without proper path restrictions. This allows an attacker controlling the .gitmodules file to cause the parser to read arbitrary local files. When the included file is not a valid git config, the parser raises an exception that leaks the first line of the file in the error message. This leads to local file content disclosure of the first line of any readable file on the victim's system during routine submodule enumeration.

References

Community reviews

Loading reviews…