Skip to main content
CVE-2026-67323VulnerabilityPublished Updated

nbdime · GitPython: command injection via unguarded Git options in `Repo.archive()`, `git.ls_remote()`, and arbitrary file

Affects nbdimeSource GCVE Database

0
Authoritative record:CVE-2026-67323· High 8.6

Not known to be exploited · CVSS 8.6 High : upgrade to 4.0.4_4 soon.

Data as of 26 Oct 2026, 17:27 UTC

CVSS 4.0 base score
8.6High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
1.2% chance of exploitation in 30 days – higher than 69% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 4.0.4_4
CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 1 Aug 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade nbdime to 4.0.4_4.

Affected software

ProductAffectedFixed in
Homebrewnbdimepkg:brew/nbdimeOther threatsAffected
  • >=1.1.0 <4.0.4_4
Fixed in
  • 4.0.4_4

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade GitPython to version 4.0.4_4 or later, where the unsafe command injection vectors have been addressed. Until upgrading, avoid passing untrusted input as keyword arguments to GitPython methods that construct Git command options, such as Repo.archive(), git.ls_remote(), Repo.iter_commits(), and Repo.blame().

Description

GitPython versions from 1.1.0 up to but not including 4.0.4_4 contain command injection vulnerabilities due to insufficient validation of user-supplied options in several Git command wrappers, including Repo.archive(), git.ls_remote(), and others. This allows an attacker to execute arbitrary commands or cause file truncation by crafting malicious arguments. The issue arises because certain keyword arguments are transformed into Git command options without proper sanitization, enabling injection of commands via options like --exec or upload-pack. A fix is available in version 4.0.4_4.

References

Community reviews

Loading reviews…