Skip to main content
VulnerabilityPublished Updated

CVE-2026-78676: GitPython · Dormant multi-line git-config values are corrupted into live injected directives (e.g

Affects nbdimeSource GCVE Database

0
Authoritative record:CVE-2026-78676· Critical 9.3

Not known to be exploited · CVSS 9.3 Critical : upgrade to 4.0.4_8 as a priority.

Data as of 26 Oct 2026, 17:28 UTC

CVSS 4.0 base score
9.3Critical
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.7% chance of exploitation in 30 days – higher than 55% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 4.0.4_8
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 25 Aug 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade nbdime to 4.0.4_8.

Affected software

ProductAffectedFixed in
Homebrewnbdimepkg:brew/nbdimeOther threatsAffected
  • >=1.1.0 <4.0.4_8
Fixed in
  • 4.0.4_8

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available in GitPython version 4.0.4_8 that fixes the unsafe re-serialization of multi-line config values. Users should upgrade to version 4.0.4_8 or later to remediate this vulnerability. Until patched, avoid performing config writes with GitPython on repositories that may contain untrusted multi-line config values. The vendor advisory confirms the availability of an official fix.

Description

GitPython versions from 1.1.0 up to but not including 4.0.4_8 contain a vulnerability in the handling of multi-line git config values. When a multi-line value is read from disk and later rewritten by GitPython, the re-serialization process corrupts the value, injecting new live git config directives. This can lead to arbitrary code execution via the core.hooksPath configuration, which is honored by git hook operations.

References

Community reviews

Loading reviews…