Skip to main content
CVE-2026-73622VulnerabilityPublished Updated

nbdime · GitPython: Environment-variable exfiltration via Repo.create_remote() / Remote.add() URL (incomplete fix of

Affects nbdimeSource GCVE Database

0
Authoritative record:CVE-2026-73622· High 8.7

Not known to be exploited · CVSS 8.7 High : upgrade to 4.0.4_5 soon.

Data as of 26 Oct 2026, 17:26 UTC

CVSS 4.0 base score
8.7High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.5% chance of exploitation in 30 days – higher than 43% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 4.0.4_5
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 13 Aug 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade nbdime to 4.0.4_5.

Affected software

ProductAffectedFixed in
Homebrewnbdimepkg:brew/nbdimeOther threatsAffected
  • >=1.1.0 <4.0.4_5
Fixed in
  • 4.0.4_5

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available in GitPython version 4.0.4_5 that disables environment variable expansion in these API calls. Users should upgrade to version 4.0.4_5 or later to remediate this vulnerability. Until upgraded, avoid passing untrusted URLs to Repo.create_remote() or Remote.add() that could contain environment variable references. No other mitigations are specified by the vendor.

Description

GitPython versions from 1.1.0 up to but not including 4.0.4_5 contain a vulnerability where environment variables in URLs passed to Repo.create_remote() or Remote.add() are expanded and embedded into the repository configuration. This can lead to sensitive environment variables being exfiltrated to attacker-controlled hosts during git fetch or pull operations. The vulnerability arises because the fix for a previous similar issue did not cover these API calls, leaving the default behavior of expanding environment variables in URLs intact. A patch is available in version 4.0.4_5 that addresses this issue.

References

Community reviews

Loading reviews…