Skip to main content
VulnerabilityPublished Updated

CVE-2026-69097: GitPython · git-config section-name injection enables arbitrary config directives (core.sshCommand RCE)

Affects jiratuiSource GCVE Database

0
Compare
Authoritative record:CVE-2026-69097· High 7.3

Not known to be exploited · CVSS 7.3 High : upgrade to 1.10.1_1 soon.

Data as of 30 Oct 2026, 08:44 UTC

CVSS 4.0 base score
7.3High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 1.10.1_1
CVSS:4.0/AV:L/AC:H/AT:P/PR:N/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 3 Aug 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade jiratui to 1.10.1_1.

Affected software

ProductAffectedFixed in
Homebrewjiratuipkg:brew/jiratuiOther threatsAffected
  • >=1.3.0 <1.10.1_1
Fixed in
  • 1.10.1_1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available and fixed the vulnerability in GitPython version 3.1.53 and later. Users should upgrade to version 3.1.53 or newer to remediate this issue. Until patched, avoid using untrusted submodule names or repositories. No other mitigations are documented.

Description

GitPython versions up to 3.1.52 contain a vulnerability where specially crafted submodule names can inject arbitrary configuration directives into the .git/config file. This occurs because section names are not properly escaped, allowing an attacker to inject directives like core.sshCommand, which can lead to remote code execution during subsequent git operations. The vulnerability arises from insufficient sanitization of section names, specifically allowing characters that break the config section header syntax on the same line. A fix is available in version 3.1.53 and later.

References

Community reviews

Loading reviews…